How to setup PPPoE, NAT, DHCP server on Cisco Router
Set up PPPoE, DHCP server, NAT in router cisco.
Figure:
Configuration file:
-------------------------------------------------------------------------------------------------
Current configuration : 1489 bytes
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
!#########Create DHCP Server###########
ip dhcp pool InternalIP
network 192.168.1.0 255.255.255.0
dns-server 203.189.128.2 203.189.128.1
default-router 192.168.1.1
!######################################
!
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO2821 sn FGL151311SM
username cisco password 0 cisco
!
!
!
!
!
!
!##############Enable PPPoE client on GigabitEthernet0/0##########
interface GigabitEthernet0/0
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!##################################################################
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
!###########setup PPPoE dialer 0 interface#################
interface Dialer0
description Connect to ONLINE
ip address negotiated
ip mtu 1454
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username Your_Username password 0 Your_Password
no cdp enable
!###########################################################
!
ip forward-protocol nd
!
!
no ip http server
###########Setup NAT########################
ip nat inside source list 99 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 99 permit 192.168.1.0 0.0.0.255
######################################
!
!
control-plane
!
!
line con 0
login local
line aux 0
!##########Enable Telnet Access#########################
line vty 0 4
privilege level 15
password onlinecisco
login
!#######################################################
!
scheduler allocate 20000 1000
end
Figure:
Configuration file:
-------------------------------------------------------------------------------------------------
Current configuration : 1489 bytes
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
!#########Create DHCP Server###########
ip dhcp pool InternalIP
network 192.168.1.0 255.255.255.0
dns-server 203.189.128.2 203.189.128.1
default-router 192.168.1.1
!######################################
!
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO2821 sn FGL151311SM
username cisco password 0 cisco
!
!
!
!
!
!
!##############Enable PPPoE client on GigabitEthernet0/0##########
interface GigabitEthernet0/0
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!##################################################################
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
!###########setup PPPoE dialer 0 interface#################
interface Dialer0
description Connect to ONLINE
ip address negotiated
ip mtu 1454
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username Your_Username password 0 Your_Password
no cdp enable
!###########################################################
!
ip forward-protocol nd
!
!
no ip http server
###########Setup NAT########################
ip nat inside source list 99 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 99 permit 192.168.1.0 0.0.0.255
######################################
!
!
control-plane
!
!
line con 0
login local
line aux 0
!##########Enable Telnet Access#########################
line vty 0 4
privilege level 15
password onlinecisco
login
!#######################################################
!
scheduler allocate 20000 1000
end
No comments:
Post a Comment